top of page

Dance Workshops

Public·33 members
James White
James White

Toontrack EZdrummer 2.1.1



Hi i have download the EZX hiphop add on, and it comes up with message saying i need to update toontrack software. What do i do now? I have Superior Drummer 2.4.0 64 bit. As it says that is required. Thanks




Toontrack EZdrummer 2.1.1



HI i have purchase ezdrummer2 on your website then i download and install it on my mac everything is good.then i purchase hiphop ezx when i try to install it i have the message that i need to upgrade to the latest version.how can i do to install it?


About

Welcome to the dance workshop group! You can connect with ot...

Members

bottom of page